《Netty官方文档》设置开发环境

原文链接 译者:dan   QQ:903585177

请注意:这个指南并不是用户指南,它是开发 Netty 本身的指南,而不是使用Netty 开发其他程序的指南。

  • 使用64位操作系统
    必须使用64位操作系统
  • 安装必须的构建工具
    64位JDK8或者以上,Apache Maven 3.1.1或者以上,Git。如果你是Linux系统,你不得不安装下列包:
    # yum install lsb-core autoconf automake libtool make tar \
    glibc-devel libaio-devel openssl-devel apr-devel \
    lksctp-tools
    # apt-get install autoconf automake libtool make tar \
    libaio-dev libssl-dev libapr1-dev \
    lksctp-tools
  • 配置Git结束命令
    对于源代码,我们使用本地命令行结束(i.e. ‘\n’ for *nix and MacOS X, ‘\r\n’ for Windows.),为了防止你构建失败,请配置你的Git,如果你提交了错误的文件,请遵守一下指示:
    Dealing with line endingsby Github
    Mind the End of Your Lineby Tim Clem, for more information
  • 使用IntelliJ IDEA
    Netty 项目项目组使用IntelliJ IDEA作为主要的IDE,但是我们也可以根据自已的编码习惯使用不同的开发环境
  • 版本位数与你的系统一致
    如果你是要64位操作系统,使用IntelliJ IDEA 64位版本,比如,即使您使用的是64位Windows,启动菜单快捷方式也会指向32位二进制文件。 您必须在安装目录中找到idea64.exe,并使用它。 否则,你会看到IntelliJ IDEA抱怨它找不到io.netty:netty-tcnative:windows-x86_32。
  • 编码风格
    下载此代码样式配置,并将Netty project.xml解压缩到 / codestyles目录中。 选择“Netty项目”作为默认代码样式
  • 检验文件
    下载,解压并且导入这个检验文件到你的IntelliJ IDEA,并将它设为默认,参照下面学会如何导入一个检验文件。
    确保您的修改不会引入任何检查警告。 如果您认为这是一个假阳性,请在IDE引导下使用@SuppressWarnings注释或noinspection行注释来抑制警告。 有关使用检查器的更多信息,请参阅Web帮助页面。
  • 版权文件
    版权文件:
    Copyright $today.year The Netty ProjectThe Netty Project licenses this file to you under the Apache License,
    version 2.0 (the “License”); you may not use this file except in compliance
    with the License. You may obtain a copy of the License at:
    http://www.apache.org/licenses/LICENSE-2.0
    Unless required by applicable law or agreed to in writing, software
    distributed under the License is distributed on an “AS IS” BASIS, WITHOUT
    WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
    License for the specific language governing permissions and limitations
    under the License.
    在评论中检测版权的关键字:
    The Netty project licenses
    如果旧版权包含以下内容,请允许替换版权:
    The Netty project licenses
  • 使用Eclipse 以及 M2E 和 Java 7/8
    1.确保使用64位版本Eclipse
    2.下载os-maven-plugin并将其放入 / plugins(Eclipse 4.5)或 / dropins(Eclipse 4.6)目录中,以解决m2e不评估我们的pom.xml中指定的扩展名的问题。 (与其名称不同,它既是Maven插件又是Eclipse插件。)
    3.导入项目方式:通过菜单’File → Import… → Existing Maven Projects’
    4.Netty项目Maven pom.xml设置规定使用Java SE 1.6,同时隐式使用Java 7/8(1.7 / 1.8)功能(如果存在)。 这可能会导致Eclipse中的编译错误。 有两种方法来解决这个问题:
    5.寻找 ‘Window → Preferences → Installed JRE’ 菜单:
    确保您在“Installed JRE”下安装了Java 7/8安装
    将此Java 7/8安装映射到Java 6:“Installed JRE→Execution Environments”→“Java SE 1.6”或者,可以为每个Netty模块在每个项目的基础上选择Java 7/8 JRE。

原创文章,转载请注明: 转载自并发编程网 – ifeve.com本文链接地址: 《Netty官方文档》设置开发环境



FavoriteLoading添加本文到我的收藏
  • Trackback are closed
  • Comments (0)
  1. No comments yet.

You must be logged in to post a comment.

return top